Wednesday, 20 November 2013 18:25

Joomla Compatibility Update: BNR Content for K2

BNR is pleased to announce that the popular extension BNR Content for K2 has been updated for Joomla 3.x compatibility. The module should now work with all Joomla 2.5 and 3.x versions.

Go To Top